const regex = new RegExp('([k,K]ıdem [t,T]azminatı )(?![ö,Ö]deme)', 'g')
const str = `- Amortisman ve İtfa Payları
- Kıdem Tazminatı Karşılığı
- Kıdem tazminatı ödemesi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}