package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(: \)| =\)| :-\))`)
var str = `Тут ÑкийÑÑŒ текÑÑ‚ : ) Ñ– тут ÑкийÑÑŒ текÑÑ‚ =) ще текÑÑ‚ :-)`
var substitution = ":)"
fmt.Println(re.ReplaceAllString(str, substitution))
}