// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(: \)| =\)| :-\))").unwrap();
let string = "Тут ÑкийÑÑŒ текÑÑ‚ : ) Ñ– тут ÑкийÑÑŒ текÑÑ‚ =) ще текÑÑ‚ :-)";
let substitution = ":)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}