re = /(: \)| =\)| :-\))/
str = 'Тут ÑкийÑÑŒ текÑÑ‚ : ) Ñ– тут ÑкийÑÑŒ текÑÑ‚ =) ще текÑÑ‚ :-)'
subst = ':)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result