import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "HbbTV\\/\\d+\\.\\d+\\.\\d+\\s\\((.*);\\s(.*);\\s(.*);\\s(.*);\\s(.*);\\)";
final String string = "HbbTV/1.2.1 (+PVR; Topfield; TRF-8800HD; HTFA.1.00.00; v1.0.1;)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}