use strict;
my $str = 'HbbTV/1.2.1 (+PVR; Topfield; TRF-8800HD; HTFA.1.00.00; v1.0.1;)';
my $regex = qr/HbbTV\/\d+\.\d+\.\d+\s\((.*);\s(.*);\s(.*);\s(.*);\s(.*);\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}