// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"HbbTV\/\d+\.\d+\.\d+\s\((.*);\s(.*);\s(.*);\s(.*);\s(.*);\)").unwrap();
let string = "HbbTV/1.2.1 (+PVR; Topfield; TRF-8800HD; HTFA.1.00.00; v1.0.1;)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}