re = /HbbTV\/\d+\.\d+\.\d+\s\((.*);\s(.*);\s(.*);\s(.*);\s(.*);\)/
str = 'HbbTV/1.2.1 (+PVR; Topfield; TRF-8800HD; HTFA.1.00.00; v1.0.1;)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end