using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0(\.\d{1,4})?|1(\.0{1,4})?)$";
string input = @"0
0.1
0.12
0.123
0.1234
1
Not allowed
-0.1
-1
1.1
2
0.12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}