$re = '/^(0(\.\d{1,4})?|1(\.0{1,4})?)$/m';
$str = '0
0.1
0.12
0.123
0.1234
1
Not allowed
-0.1
-1
1.1
2
0.12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);