package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0(\.\d{1,4})?|1(\.0{1,4})?)$`)
var str = `0
0.1
0.12
0.123
0.1234
1
Not allowed
-0.1
-1
1.1
2
0.12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}