const regex = /^(0(\.\d{1,4})?|1(\.0{1,4})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0(\\.\\d{1,4})?|1(\\.0{1,4})?)$', 'gm')
const str = `0
0.1
0.12
0.123
0.1234
1
Not allowed
-0.1
-1
1.1
2
0.12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}