#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[a-zA-Z][1-9]@[gmail].com""
Local $sString = "2[23 3] + [1 22 3] + 7" & @CRLF & _
"[2] + [12351]" & @CRLF & _
"12[45 12]" & @CRLF & _
"[56]" & @CRLF & _
"[2] + 1 + [2]" & @CRLF & _
"2[2 a]" & @CRLF & _
"1[2 3 4] + []" & @CRLF & _
"3[2 3 4] + a[1 2 3] " & @CRLF & _
"3[2 3 4] +"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")