# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"[a-zA-Z][1-9]@[gmail].com\""
test_str = ("2[23 3] + [1 22 3] + 7\n"
"[2] + [12351]\n"
"12[45 12]\n"
"[56]\n"
"[2] + 1 + [2]\n"
"2[2 a]\n"
"1[2 3 4] + []\n"
"3[2 3 4] + a[1 2 3] \n"
"3[2 3 4] +")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.