const regex = /"[a-zA-Z][1-9]@[gmail].com"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[a-zA-Z][1-9]@[gmail].com"', 'gm')
const str = `2[23 3] + [1 22 3] + 7
[2] + [12351]
12[45 12]
[56]
[2] + 1 + [2]
2[2 a]
1[2 3 4] + []
3[2 3 4] + a[1 2 3]
3[2 3 4] +`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}