using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[a-zA-Z][1-9]@[gmail].com""";
string input = @"2[23 3] + [1 22 3] + 7
[2] + [12351]
12[45 12]
[56]
[2] + 1 + [2]
2[2 a]
1[2 3 4] + []
3[2 3 4] + a[1 2 3]
3[2 3 4] +";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}