#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(export[^(]*)(\(([^)]+)\))([^{]*)([^{]*{)"
Local $sString = "export default function something($123, something, wauw) {" & @CRLF & _
" " & @CRLF & _
" function(random) {" & @CRLF & _
" return random;" & @CRLF & _
"" & @CRLF & _
" function(woo) {" & @CRLF & _
" return "wow";" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"export default function(something, wauw) {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
" " & @CRLF & _
""
Local $sSubst = "$1$2$4$5\nthis.$ngInject = [$3]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)