import re
regex = re.compile(r"(export[^(]*)(\(([^)]+)\))([^{]*)([^{]*{)")
test_str = ("export default function something($123, something, wauw) {\n"
" \n"
" function(random) {\n"
" return random;\n\n"
" function(woo) {\n"
" return \"wow\";\n"
" }\n"
" }\n"
"}\n\n\n"
"export default function(something, wauw) {\n\n"
"}\n"
" \n")
subst = "$1$2$4$5\\nthis.$ngInject = [$3]"
result = regex.sub(subst, test_str)
if result:
print(result)