using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(export[^(]*)(\(([^)]+)\))([^{]*)([^{]*{)";
string substitution = @"$1$2$4$5\nthis.$ngInject = [$3]";
string input = @"export default function something($123, something, wauw) {
function(random) {
return random;
function(woo) {
return ""wow"";
}
}
}
export default function(something, wauw) {
}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}