import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(export[^(]*)(\\(([^)]+)\\))([^\\{]*)([^\\{]*\\{)";
final String string = "export default function something($123, something, wauw) {\n"
+ " \n"
+ " function(random) {\n"
+ " return random;\n\n"
+ " function(woo) {\n"
+ " return \"wow\";\n"
+ " }\n"
+ " }\n"
+ "}\n\n\n"
+ "export default function(something, wauw) {\n\n"
+ "}\n"
+ " \n";
final String subst = "$1$2$4$5\\nthis.$ngInject = [$3]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}