const regex = /(\w+)\s{2,}.*\+(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s{2,}.*\\+(\\d+)', 'g')
const str = `Johnny Alan Walker Sint Jansstraat 7, 1012 HG Amsterdam +123456789012`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}