$re = '/(\w+)\s{2,}.*\+(\d+)/';
$str = 'Johnny Alan Walker Sint Jansstraat 7, 1012 HG Amsterdam +123456789012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);