re = /(\w+)\s{2,}.*\+(\d+)/
str = 'Johnny Alan Walker Sint Jansstraat 7, 1012 HG Amsterdam +123456789012'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end