import re
regex = re.compile(r"(\w+)\s{2,}.*\+(\d+)")
test_str = "Johnny Alan Walker Sint Jansstraat 7, 1012 HG Amsterdam +123456789012"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")