#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^__|.*thumb\.(gif|jpg|png|jpeg))(^.*)(?=\.(gif|jpg|png|jpeg)$)"
Local $sString = "__abcd" & @CRLF & _
"thumbs.jpg" & @CRLF & _
"somethumb.jpg" & @CRLF & _
"thumb.jpg" & @CRLF & _
"abcd.jpg" & @CRLF & _
"abcd.jps" & @CRLF & _
"toto.thumb.toto.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")