import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^__|.*thumb\\.(gif|jpg|png|jpeg))(^.*)(?=\\.(gif|jpg|png|jpeg)$)";
final String string = "__abcd\n"
+ "thumbs.jpg\n"
+ "somethumb.jpg\n"
+ "thumb.jpg\n"
+ "abcd.jpg\n"
+ "abcd.jps\n"
+ "toto.thumb.toto.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}