re = /(?!^__|.*thumb\.(gif|jpg|png|jpeg))(^.*)(?=\.(gif|jpg|png|jpeg)$)/m
str = '__abcd
thumbs.jpg
somethumb.jpg
thumb.jpg
abcd.jpg
abcd.jps
toto.thumb.toto.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end