$re = '/(?!^__|.*thumb\.(gif|jpg|png|jpeg))(^.*)(?=\.(gif|jpg|png|jpeg)$)/m';
$str = '__abcd
thumbs.jpg
somethumb.jpg
thumb.jpg
abcd.jpg
abcd.jps
toto.thumb.toto.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);