using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,\d*?)0+\b";
string substitution = @"$1";
string input = @"123,90
123,00
123,0
123,0090
00,34
ABC";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}