package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(,\d*?)0+\b`)
var str = `123,90
123,00
123,0
123,0090
00,34
ABC`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}