$re = '/(,\d*?)0+\b/';
$str = '123,90
123,00
123,0
123,0090
00,34
ABC';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;