const regex = /(,\d*?)0+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,\\d*?)0+\\b', 'g')
const str = `123,90
123,00
123,0
123,0090
00,34
ABC`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);