using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",?(?!CN\d+)\b[\w~ -]+";
string substitution = @"";
string input = @"CN98765432~-~ECN for A01234 Rev A,CR00098765~-~ECR for A12345 SOME PART NAME,CN12345678~-~ECN for A12345 Rev A";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}