import Foundation
let pattern = #",?(?!CN\d+)\b[\w~ -]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"CN98765432~-~ECN for A01234 Rev A,CR00098765~-~ECR for A12345 SOME PART NAME,CN12345678~-~ECN for A12345 Rev A"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)