re = /,?(?!CN\d+)\b[\w~ -]+/
str = 'CN98765432~-~ECN for A01234 Rev A,CR00098765~-~ECR for A12345 SOME PART NAME,CN12345678~-~ECN for A12345 Rev A'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result