package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)(https?):\/\/(\[[\:[:xdigit:]]+\]|[-\.[:alnum:]]+)(:(\d+))?(\/.*)`)
    var str = `http://[e::]:8081/mStoreRoot/fms/v1/tenant/mavenir/MoH/files/MoH/EN/musiconhold/calls/1.mp3`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}