import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?):\\/\\/(\\[[\\:[:xdigit:]]+\\]|[-\\.[:alnum:]]+)(:(\\d+))?(\\/.*)";
final String string = "http://[e::]:8081/mStoreRoot/fms/v1/tenant/mavenir/MoH/files/MoH/EN/musiconhold/calls/1.mp3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}