import Foundation
let pattern = #"(https?):\/\/(\[[\:[:xdigit:]]+\]|[-\.[:alnum:]]+)(:(\d+))?(\/.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://[e::]:8081/mStoreRoot/fms/v1/tenant/mavenir/MoH/files/MoH/EN/musiconhold/calls/1.mp3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)