use strict;
my $str = 'http://[e::]:8081/mStoreRoot/fms/v1/tenant/mavenir/MoH/files/MoH/EN/musiconhold/calls/1.mp3';
my $regex = qr/(https?):\/\/(\[[\:[:xdigit:]]+\]|[-\.[:alnum:]]+)(:(\d+))?(\/.*)/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}