#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$|\,|\(|\)|@|\."
Local $sString = "$16,500,000(@$2,500)" & @CRLF & _
"$34,000(@$11.00)" & @CRLF & _
"$214,000(@$18.00)" & @CRLF & _
"$12,684,000(@$3,800) "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)