import re
regex = re.compile(r"\$|\,|\(|\)|@|\.")
test_str = ("$16,500,000(@$2,500)\n"
"$34,000(@$11.00)\n"
"$214,000(@$18.00)\n"
"$12,684,000(@$3,800) ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)