const regex = /\$|\,|\(|\)|@|\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$|\\,|\\(|\\)|@|\\.', 'g')
const str = `\$16,500,000(@\$2,500)
\$34,000(@\$11.00)
\$214,000(@\$18.00)
\$12,684,000(@\$3,800) `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);