#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\[cid:(?:[0-9A-Z-]{7,8}){5}\])"
Local $sString = "[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]" & @CRLF & _
"[cid:" & @CRLF & _
"B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]" & @CRLF & _
"[pid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]" & @CRLF & _
"[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]" & @CRLF & _
"[cid:B54FD]" & @CRLF & _
"[cid:B54FD59F-8DE7-4ED1-A0CU]-[3A8D7]-[19E52F83A8D7]" & @CRLF & _
"" & @CRLF & _
"// lowercase won't match unless you include /i" & @CRLF & _
"" & @CRLF & _
"[cid:2992S39a-1111-EEEE-9999-1239992EEIUE]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)