# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[cid:(?:[0-9A-Z-]{7,8}){5}\])"
test_str = ("[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
"[cid:\n"
"B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
"[pid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
"[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
"[cid:B54FD]\n"
"[cid:B54FD59F-8DE7-4ED1-A0CU]-[3A8D7]-[19E52F83A8D7]\n\n"
"// lowercase won't match unless you include /i\n\n"
"[cid:2992S39a-1111-EEEE-9999-1239992EEIUE]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.