using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[cid:(?:[0-9A-Z-]{7,8}){5}\])";
string substitution = @"";
string input = @"[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]
[cid:
B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]
[pid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]
[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]
[cid:B54FD]
[cid:B54FD59F-8DE7-4ED1-A0CU]-[3A8D7]-[19E52F83A8D7]
// lowercase won't match unless you include /i
[cid:2992S39a-1111-EEEE-9999-1239992EEIUE]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}