import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[cid:(?:[0-9A-Z-]{7,8}){5}\\])";
final String string = "[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
+ "[cid:\n"
+ "B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
+ "[pid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
+ "[cid:B54FD59F-8DE7-4ED1-A0C7-19E52F83A8D7]\n"
+ "[cid:B54FD]\n"
+ "[cid:B54FD59F-8DE7-4ED1-A0CU]-[3A8D7]-[19E52F83A8D7]\n\n"
+ "// lowercase won't match unless you include /i\n\n"
+ "[cid:2992S39a-1111-EEEE-9999-1239992EEIUE]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}