using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!boy$).*";
string input = @"hola.com/reverse=1&_=1502991759324&ignoremeN=21&boy=1&bg=d
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}