$re = '/^(?!boy$).*/';
$str = 'hola.com/reverse=1&_=1502991759324&ignoremeN=21&boy=1&bg=d
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);