re = /^(?!boy$).*/
str = 'hola.com/reverse=1&_=1502991759324&ignoremeN=21&boy=1&bg=d
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end