const regex = /^(?!boy$).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!boy$).*', '')
const str = `hola.com/reverse=1&_=1502991759324&ignoremeN=21&boy=1&bg=d
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}